Introduction

Lorsque vous accédez à l'aide d'un utilitaire, la documentation est affichée dans la visionneuse Web utilisant un fichier d'aide local (.chm).

  • Accéder à l' aide .
  • Généralités sur les utilitaires.
  • Présentation de l'utilitaire
  • Mentions légales .

Copyright © 2014 by Axemble. All Rights Reserved.


Accès à l'aide

Introduction ››

Bienvenue dans l’aide en ligne des utilitaires myCADtools

Depuis le répertoire d’installation des utilitaires, vous pouvez lancer l’aide en ligne (.chm, ou bien en cliquant sur l’icône [image] de l’utilitaire.

Conseils relatifs à l’utilisation de l’aide.

  • Pour sélectionner une rubrique :

Utilisez l’onglet sommaire et naviguez au travers des rubriques et des mots contenant un lien hypertexte.

  • Pour effectuer une recherche :

Cliquez sur l’onglet Rechercher, entrez un terme et cliquez sur Rechercher. Sélectionnez une rubrique et cliquez sur Afficher.

Créez des recherches booléennes à l'aide des opérateurs AND, OR, NOT et NEAR (ET, OU, SAUF et ADJ).

Sélectionnez Rechercher dans les résultats précédents afin d'utiliser uniquement les rubriques trouvées auparavant pour la recherche suivante. Cette option vous permet d'affiner votre recherche en ajoutant des mots-clés.

Sélectionnez Rechercher les mots similaires pour mettre en surbrillance les mots similaires dans les rubriques trouvées. Par exemple, si vous recherchez "pièces", vous trouverez des rubriques contenant "documents pièces" et "propriétés dans les pièces".

Sélectionnez Rechercher dans les titres uniquement pour ne trouver que les rubriques dont le titre inclut le mot-clé.

Restez connecté à la communauté Axemble

A tout moment vous pouvez vous connecter à la communauté myCADservices . Sur ce site vous trouverez une multitude d’informations techniques telles que :

    • Accès à une base documentaire contenant des tutoriaux, des FAQ, des présentations de fonctionnalités de la gamme SolidWorks etc… Cette documentation est alimentée par nos équipes techniques Axemble (Hotline, Formateurs, Consultants …).
    • Accès à une base de vidéos vous permettant d’approfondir vos connaissances sur des sujets de la gamme SolidWorks.
    • Accès à des bibliothèques de composants standard Axempble, TracePart et Cadenas.
    • Accès à des téléchargements gratuits afin d’installer les setups des utilitaires myCADtools .
    • Accès aux vidéos de formation sur les utilitaires myCADtools.
    • Accès au support Hotline (contrat de maintenance obligatoire).

Vous pouvez également suivre tous les articles et toutes les actualités pertinents sur SolidWorks et Axemble sur le site myCADblog .

Sur ce site vous trouverez un forum vous permettant de partager, avec d’autres utilisateurs, vos questions ou vos connaissances autour des utilitaires myCADtools.


Généralités des utilitaires

Introduction ››

Tous les utilitaires de la barre d'outils myCADtools présentent un bandeau identique comportant certaines informations.

Dans la partie gauche du bandeau nous retrouvons le nom de l'utilitaire suivi par le numéro de la version installée (exemple v2013.11.12).

2013→ Version de myCADtools 11→ Année du setup 12→ Mois du setup

Dans la partie droite nous avons accès à une barre d'icônes.

Possibilité de "punaiser" la fenêtre de l'utilitaire afin qu'elle ne soit pas minimisée par Windows.

Cet icône vous donne accès directement au cours afin de visualiser les vidéos de formation de l'utilitaire

Cet icône vous donne accès directement au site Axemble

Cet icône vous donne accès directement au site myCADservices

En cliquant sur cet icône vous accédez aux informations liées à l'utilitaire mais également à l'installation de l'ensemble des utilitaires du setup myCADtools.

Voici les informations disponibles dans cette fenêtre :

  • Un rappel de la version de l'utilitaire mais également la version du setup d'installation de la barre d'outils myCADtools.

  • Un rappel du code d'immatriculation ainsi que le numéro de licence SolidWorks à laquelle est rattaché ce code.

  • La date limite d'utilisation de l'utilitaire par exemple dans le cas d'une demande de prêt.

  • Le nom des utilitaires installés ainsi que, pour chacun d'entre eux, le nombre d'utilisations. Cette information peut être une bonne indication afin de connaître quels sont les utilitaires les plus souvent utilisés.

  • Une possibilité de remonter des demandes d'amélioration via votre messagerie. Un message est alors directement envoyé à notre service R&D. Vous n’avez plus que le contenu du message à rédiger.

Information pour l’exploitation des données d’un coffre fort ePDM avec certains outils myCADtools.

Les utilitaires de la suite myCADtools ne sont pas développés pour être utilisés dans un environnement PDM. Pour bénéficier de cette fonctionnalité, il faut impérativement avoir :

  • Installé SolidWorks Enterprise PDM

  • Installé la suite d’outils myPDMtools

  • Une licence d’immatriculation myPDMtools

Si vous n’êtes pas dans cette situation, un message apparaîtra lors de l’utilisation de certains utilitaires de myCADtools :


Mentions légales

Introduction ››

Copyright © 2014 myCAD

Avertissement: Cet outil a été réalisé par myCAD

Des portions de ce logiciel sont protégées par copyright et demeurent la propriété de :

- Copyright © 1995-2012 SolidWorks Corporation

- Copyright © 1998-2012 Geometric Software Solutions Co. Limited.

- Copyright © 1996-2012 Microsoft Corporation. Tous droits réservés.

Contrat de licence myCADtools.

AVIS À L'UTILISATEUR: VEUILLEZ LIRE ATTENTIVEMENT CE CONTRAT. EN UTILISANT TOUT OU PARTIE DES LOGICIELS myCADtools (CI-APRES LE "LOGICIEL"), VOUS ACCEPTEZ TOUTES LES DISPOSITIONS DU PRÉSENT CONTRAT.

Les Logiciels myCADtools sont :

- BatchConverter

- BatchProperties

- BeamCutOut

- CopyOptions

- CurveEquation

- CurveData

- CleanProject

- CloneComponents

- Cloud

- ColorChart

- CreatePoints

- CreateSections

- Dependencies

- DrawingTranslate

- DriveAssembly

- EasyPrint

- FaceFonts

- FontConverter

- GetCoordinates

- Integration

- LayerManager

- LocalHelp

- PilotAssembly

- PowerPrint

- ProjectManager

- ScaleDimension

- SearchPaths

- SelectMaterial

- SmartBalloons

- SmartBom

- SmartDrawings

- SmartProperties

- SmartWelding

- Tolerances

- TolerancesTable

- ToolBar myCAD

- UnitsConverter

- UnsewBody

- UpdateVersion

- VersionHistory

- Viewer

- ViewGrid

- WhereUsed

myCAD détient tous les droits de propriété intellectuelle liés au Logiciel.

1. Définitions. Le terme "Logiciel" désigne tout le contenu des fichiers, du (des) CD-ROM(s) ou de tout autre support fourni avec le présent Contrat, y compris, notamment, le (les) logiciel(s) ou données informatiques de myCAD ou de tiers, les fichiers ou documents écrits explicatifs associés correspondants (la "Documentation"), ainsi que toutes les mises à niveau, versions modifiées, mises à jour, ajouts et copies du Logiciel, s'il y a lieu, pour lesquels myCAD vous concède une licence (ci-après dénommées collectivement les "Mises à Jour"). Le terme "Utilisation" désigne l'accès au Logiciel, son installation, son téléchargement, sa copie ou tout autre avantage tiré de l'utilisation de ses fonctionnalités conformément à la Documentation.

2. Concession de Licence. Sous réserve du respect des dispositions du présent Contrat de Licence de Logiciel (le "Contrat"), myCAD vous concède une licence non exclusive d'Utilisation du Logiciel aux fins décrites dans la Documentation. Vous êtes autorisé à installer et à utiliser une copie du Logiciel, à concurrence du Nombre Autorisé d'utilisateurs.

3. Détention des droits de propriété intellectuelle et du copyright [Droit d'auteur]. Le Logiciel et toute copie autorisée que vous effectuez sont la propriété intellectuelle de myCAD et de ses fournisseurs. La structure, l'organisation et le code du Logiciel constituent des secrets commerciaux et des informations confidentielles de valeur de myCAD et de ses fournisseurs. Le Logiciel est protégé par la loi, sur le copyright [droit d'auteur], Sauf disposition expresse des présentes, le présent Contrat ne vous concède aucun droit de propriété intellectuelle sur le Logiciel, et myCAD et ses fournisseurs se réservent tous les droits qui ne sont pas expressément concédés.

4. Limitations. Vous n'êtes pas autorisé à copier le Logiciel sauf pour effectuer une copie de sauvegarde du logiciel. Vous n'êtes pas autorisé à modifier, adapter ou traduire le Logiciel. Vous n'effectuerez pas d'ingénierie inverse et vous n'êtes pas autorisé à décompiler, désassembler le Logiciel, essayer de toute autre façon de découvrir son code source, redevance raisonnable avant de vous fournir de telles informations. Vous ne pouvez pas louer ou donner en crédit bail, sous-licencier, céder ou transférer vos droits relatifs au Logiciel, ou autoriser la copie de tout ou partie du Logiciel.

5. Mises à Jour. Si le Logiciel est une Mise à Jour d'une version antérieure du Logiciel, vous devez détenir une licence en vigueur pour cette version antérieure pour pouvoir utiliser la Mise à Jour. Toutes les mises à jour sont fournies sur la base d’un contrat de mises à jour.

6. EXCLUSION DE GARANTIE. Le Logiciel est livré "EN L’ÉTAT" et myCAD ne consent aucune garantie relative à son Utilisation ou ses performances. myCAD ET SES FOURNISSEURS NE GARANTISSENT PAS ET NE PEUVENT PAS GARANTIR LES PERFORMANCES OU LES RÉSULTATS OBTENUS EN UTILISANT LE LOGICIEL.

7. LIMITATION DE RESPONSABILITÉ. EN AUCUN CAS myCAD OU SES FOURNISSEURS NE SERONT RESPONSABLES DE TOUS DOMMAGES, RÉCLAMATIONS OU COÛTS DE QUELQUE NATURE QUE CE SOIT, OU POUR TOUS DOMMAGES DIRECTS, INDIRECTS OU INCIDENTS, POUR TOUT MANQUE À GAGNER, ET CE MÊME SI UN REPRÉSENTANT de myCAD A ÉTÉ INFORMÉ DE LA POSSIBILITÉ DE TELS DOMMAGES, PERTES, RÉCLAMATIONS OU COÛTS, OU DE TOUTE RECLAMATION D’UN TIERS.

8. Loi applicable. Le présent Contrat est régi par loi française. En cas de litige, le tribunal de commerce de Lyon sera seul compétent.

9. Conformité aux licences. Si vous êtes une société ou une organisation, vous vous engagez à prouver et certifier, dans un délai de trente (30) jours, à la demande de myCAD ou d'un de ses représentants autorisés, qu'à la date de ladite demande, l’Utilisation des Logiciels est conforme aux licences en vigueur concédées par myCAD.

Pour toute demande d'information, veuillez vous adresser au Service Clientèle de myCAD.


Présentation de l'utilitaire "LocalHelp"

LocalHelp [image] permet d'afficher une liste de raccourcis dans le Volet des tâches de SolidWorks. Ces raccourcis peuvent être associés à tous types de documents Windows ou à des liens URL.

Vous pouvez ainsi intégrer la documentation propre à votre société directement dans l'interface SolidWorks.

Les informations visibles dans le Volet des tâches est personnalisable voir l'utilisation de LocalHelp .


Utilisation de l'utilitaire "LocalHelp"

Pour personnaliser et paramétrer le Volet des tâches SolidWorks cliquer sur l'icône [image] .


Paramétrage

Utilisation de l'utilitaire "LocalHelp" ››

Des liens peuvent être soit :

    • Ajoutés

    • Modifiés

    • Supprimés

Pour modifier ou supprimer un lien, il faut au préalable le sélectionner dans la liste.

Quelques options peuvent être réglées.


Liens

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ››

Les boutons (ou informations dans le Volet des tâches SolidWorks) peuvent être définis comme suit :

    • Type " Lien "
    • Type " Fichier "
    • Type " Dossier "
    • Type " Commande SolidWorks "

En fonction du type sélectionné, l’icône pour l'image sera appliqué par défaut. Il est néanmoins possible de sélectionner une autre image en cliquant sur [image] . Les formats supportés sont les standards [image] .

Les informations peuvent être placées dans des groupes .

Cette information peut également être de type " Menu déroulant ".


Type lien

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ›› Liens ››

L'aspect d'un lien peut prendre l'apparence d'un bouton ou d'un texte libre, avec ou sans info bulle.

Dans l'exemple ci-dessus la localisation :

    • Est de type "Lien" et pointera sur un lien URL (http://www.mycadservices.com).
    • Le style a l'apparence d'un bouton.
    • Le nom dans le bouton est égal à "myCADservices".
    • Éventuellement, pour faire apparaître un autre icône (exemple [image] ) il suffit d'aller chercher une image en cliquant sur [image] .
    • On indique, dans la partie "Info Bulle", le texte qui apparaîtra sous le curseur.

Dans l'exemple ci-dessus la localisation :

    • Est de type "Lien" et pointera sur un lien URL (http://www.mycadblog.fr).
    • Le style a l'apparence d'un texte simple.
    • Le nom dans le bouton est égal à "myCADblog".
    • Éventuellement, pour faire apparaître un autre icône (exemple [image] ) il suffit d'aller chercher une image en cliquant sur [image] .
    • "Info Bulle" non renseigné.


Type Fichier

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ›› Liens ››

En créant ce type de bouton il est possible de donner accès aux utilisateurs, sans quitter l'environnement SolidWorks, à tous les supports documentaires qui existent dans la société quelque soit l'emplacement où ils se trouvent (réseau ou local). En fonction du type de fichier, une image est appliquée par défaut.

En cliquant sur l'icône [image] on pointe sur le fichier à visualiser. Le fichier pointé peut être de n'importe quel type : Word, Excel, image, texte (txt), pdf, chm etc...

Une "Info Bulle" peut être saisie si le nom du bouton n'est pas explicite.


Type Dossier

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ›› Liens ››

En créant ce type de bouton il est possible d'accéder immédiatement au contenu d'un répertoire particulier en cliquant sur [image] , cet emplacement peut se trouver sur le réseau ou en local.

Si l'option "Ouvrir le dossier dans SolidWorks" est cochée, cela exécute la fonction "Ouvrir" de SolidWorks.


Type Commande SolidWorks

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ›› Liens ››

Ce type de localisation permet d'exécuter des fonctions SolidWorks (Ouvrir, Nouveau, Options SW, Propriétés, Propriétés de masse ou Mesurer). Il n'est pas possible d'en ajouter.


Groupes

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ›› Liens ››

Un certain nombre d'informations peuvent être regroupées au sein d'un groupe. On donne ici le nom du groupe avec éventuellement une "Info Bulle" si le nom n'est pas suffisamment explicite.

Les informations ainsi créées dans la liste, peuvent être déplacées tout simplement par un Glisser/Déposer avec le curseur, d'un groupe à l'autre ou à l'intérieur d'un groupe.

Lors de l'ajout ou de la modification d'un groupe il est possible de forcer l'affichage du contenu en mode réduit si l'on coche l'option [image] .

Il est toutefois possible, une fois le Volet des tâches affiché, de développer [image] ou de [image] réduire un groupe.


Menu déroulant

Utilisation de l'utilitaire "LocalHelp" ›› Paramétrage ›› Liens ››

La localisation de type "Menu déroulant" permet de définir un chemin (réseau ou local) afin d'afficher le contenu dans un menu déroulant.

La liste de ce menu répond au choix du filtre sélectionné :

L'Info Bulle est toujours là pour aider l'utilisateur à comprendre le bouton créé :


Options

Utilisation de l'utilitaire "LocalHelp" ››

Deux options disponibles :

  • Une image peut être ajoutée en pied de page [image] , les formats supportés sont les standards [image] .
  • Le paramétrage du Volet des tâches LocalHelp est enregistré dans un fichier, cet emplacement [image] peut se trouver sur le réseau ou en local. Si plusieurs utilisateurs doivent utiliser le même paramétrage il est préférable de partager ce dossier.