Introduction

Lorsque vous accédez à l'aide d'un utilitaire, la documentation est affichée dans la visionneuse Web utilisant un fichier d'aide local (.chm).

  • Accéder à l' aide .
  • Généralités sur les utilitaires.
  • Présentation de l'utilitaire
  • Mentions légales .

Copyright © 2016 by Visiativ. All Rights Reserved.


Accès à l'aide

Introduction ››

Bienvenue dans l’aide en ligne des utilitaires myCADtools

Depuis le répertoire d’installation des utilitaires, vous pouvez lancer l’aide en ligne (.chm, ou bien en cliquant sur l’icône [image] de l’utilitaire.

Conseils relatifs à l’utilisation de l’aide.

  • Pour sélectionner une rubrique :

Utilisez l’onglet sommaire et naviguez au travers des rubriques et des mots contenant un lien hypertexte.

  • Pour effectuer une recherche :

Cliquez sur l’onglet Rechercher, entrez un terme et cliquez sur Rechercher. Sélectionnez une rubrique et cliquez sur Afficher.

Créez des recherches booléennes à l'aide des opérateurs AND, OR, NOT et NEAR (ET, OU, SAUF et ADJ).

Sélectionnez Rechercher dans les résultats précédents afin d'utiliser uniquement les rubriques trouvées auparavant pour la recherche suivante. Cette option vous permet d'affiner votre recherche en ajoutant des mots-clés.

Sélectionnez Rechercher les mots similaires pour mettre en surbrillance les mots similaires dans les rubriques trouvées. Par exemple, si vous recherchez "pièces", vous trouverez des rubriques contenant "documents pièces" et "propriétés dans les pièces".

Sélectionnez Rechercher dans les titres uniquement pour ne trouver que les rubriques dont le titre inclut le mot-clé.

Restez connecté à la communauté Visiativ

A tout moment vous pouvez vous connecter à la communauté myCADservices. Sur ce site vous trouverez une multitude d’informations techniques telles que :

    • Accès à une base documentaire contenant des tutoriaux, des FAQ, des présentations de fonctionnalités de la gamme SolidWorks etc… Cette documentation est alimentée par nos équipes techniques Visiativ (Hotline, Formateurs, Consultants …).
    • Accès à une base de vidéos vous permettant d’approfondir vos connaissances sur des sujets de la gamme SolidWorks.
    • Accès à des bibliothèques de composants standard Visiativ, TraceParts et Cadenas.
    • Accès à des téléchargements gratuits afin d’installer les setups des utilitaires myCADtools.
    • Accès aux vidéos de formation sur les utilitaires myCADtools.
    • Accès au support Hotline (contrat de maintenance obligatoire).

Vous pouvez également suivre tous les articles et toutes les actualités pertinents sur SolidWorks et Visiativ sur le site myCADblog .

Sur ce site vous trouverez un forum vous permettant de partager, avec d’autres utilisateurs, vos questions ou vos connaissances autour des utilitaires myCADtools.


Généralités des utilitaires

Introduction ››

Tous les utilitaires de la barre d'outils myCADtools présentent un bandeau identique comportant certaines informations.

Dans la partie gauche du bandeau nous retrouvons le nom de l'utilitaire suivi par le numéro de la version installée (exemple v2013.11.12) :

  • 2013→ Version de myCADtools
  • 11→ Année du setup
  • 12→ Mois du setup

Dans la partie droite nous avons accès à une barre d'icônes.

Possibilité de "punaiser" la fenêtre de l'utilitaire afin qu'elle ne soit pas minimisée par Windows.

Cet icône vous donne accès directement au cours afin de visualiser les vidéos de formation de l'utilitaire

Cet icône vous donne accès directement au site Visiativ

Cet icône vous donne accès directement au site myCADservices

En cliquant sur cet icône vous accédez aux informations liées à l'utilitaire mais également à l'installation de l'ensemble des utilitaires du setup myCADtools.

Voici les informations disponibles dans cette fenêtre :

  • Un rappel de la version de l'utilitaire mais également la version du setup d'installation de la barre d'outils myCADtools.

  • Un rappel du code d'immatriculation ainsi que le numéro de licence SolidWorks à laquelle est rattaché ce code.

  • La date limite d'utilisation de l'utilitaire par exemple dans le cas d'une demande de prêt.

  • Le nom des utilitaires installés ainsi que, pour chacun d'entre eux, le nombre d'utilisations. Cette information peut être une bonne indication afin de connaître quels sont les utilitaires les plus souvent utilisés.

  • Une possibilité de remonter des demandes d'amélioration via votre messagerie. Un message est alors directement envoyé à notre service R&D. Vous n’avez plus que le contenu du message à rédiger.

Information pour l’exploitation des données d’un coffre-fort ePDM avec certains outils myCADtools.

Les utilitaires de la suite myCADtools ne sont pas développés pour être utilisés dans un environnement PDM. Pour bénéficier de cette fonctionnalité, il faut impérativement avoir :

  • Installé SolidWorks Enterprise PDM
  • Installé la suite d’outils myPDMtools
  • Une licence d’immatriculation myPDMtools

Si vous n’êtes pas dans cette situation, un message apparaîtra lors de l’utilisation de certains utilitaires de myCADtools :


Mentions légales

Introduction ››

AVIS À L'UTILISATE UR: VEUILLEZ LIRE ATTENTIVEMENT CE CONTRAT DE LICENCE LOGICIEL (CI-APRES « LICENCE » OU LE « CONTRAT ». EN CHOISSISANT DE COCHER « J’ACCEPTE LES TERMES DE LA LICENCE » ET/OU EN UTILISANT TOUT OU PARTIE DU LOGICIEL myCADtools (CI-APRES LE "LOGICIEL") EN CE INCLUS LA DOCUMENTATION, VOUS PERSONNE PHYSIQUE OU MORALE (CI-APRES DESIGNE LE « CLIENT ») ACCEPTEZ TOUTES LES DISPOSITIONS DU PRÉSENT CONTRAT.

  1. Avertissement.

Des portions du Logiciel sont protégées par copyright et demeurent la propriété de :

- Copyright © 1995-2015 Dassault Systèmes SolidWorks Corp. Tous droits réservés.

- Copyright © 1996-2015 Microsoft Corporation. Tous droits réservés.

  1. Objet. Le présent document est un accord entre vous (personne physique ou morale) (ci-après désigné le « Client ») et Visiativ. Visiativ est l’Editeur du Logiciel. Visiativ déclare qu'il est dûment habilité à consentir la présente licence d'utilisation du Logiciel. Le Client souhaite obtenir le droit d'utiliser le Logiciel après avoir pris connaissance de l'ensemble des informations relatives aux grandes fonctionnalités du Logiciel.
  2. Définitions. Le terme "Logiciel" désigne tout le contenu des fichiers, du (des) CD/DVD-ROM(s) ou de tout autre support fourni avec le présent Contrat ou disponible en téléchargement, y compris, notamment, le(s) logiciel(s) ou données informatiques de Visiativ ou de tiers, les fichiers ou documents écrits explicatifs associés correspondants (la "Documentation"), ainsi que toutes les mises à niveau, versions modifiées, mises à jour, ajouts et copies du Logiciel, s'il y a lieu, pour lesquels Visiativ concède au Client une licence (ci-après dénommées collectivement les "Mises à Jour"). Le Logiciel comprend les applications suivantes :

AssemblyBoard

BatchConverter

BatchProperties

BeamCutOut

CopyOptions

CurveEquation

CurveData

CuttingOptimization

CleanProject

CloneComponents

Cloud

ColorChart

CreatePoints

CreateSections

Dependencies

DrawingTranslate

DriveAssembly

EasyPrint

FaceFonts

FontConverter

GetCoordinates

GetCoordinates2D

GetCoordinates3D

Integration

LayerManager

LocalHelp

PilotAssembly

PowerPrint

ProjectManager

ScaleDimension

SearchPaths

SelectMaterial

SmartBalloons

SmartBom

SmartDesign

SmartDrawings

SmartProperties

SmartWelding

Tolerances

TolerancesTable

ToolBar myCAD

UnitsConverter

UnsewBody

UpdateVersion

VersionHistory

Viewer

ViewGrid

WhereUsed

Le terme "Utilisation" désigne l'accès au Logiciel, son installation, son téléchargement, sa copie ou tout autre avantage tiré de l'utilisation de ses fonctionnalités conformément à la Documentation. Le terme "Contrat d’Abonnement" (ci-après dénommé « Contrat d’Abonnement » désigne le devis, le bon de commande et/ou la proposition commerciale ainsi que le Contrat d’Abonnement, signé(e)(s) par le Client identifiant la/les licence(s) que le Client souhaite que Visiativ lui fournisse.

  3. Concession de Licence. Sous réserve du respect des dispositions du présent Contrat et particulièrement le paiement de l'intégralité de la redevance d’Abonnement correspondante à l'acquisition du présent Contrat telle qu'indiquée dans le Contrat d’Abonnement, Visiativ concède au Client un droit d'usage à titre personnel, non cessible, non transmissible et non exclusif du Logiciel.

Au titre du droit d'utilisation concédé par la présente licence d'utilisation, le Client peut utiliser le Logiciel aux fins de chargement, affichage et d’exécution conformément aux finalités décrites dans la Documentation.

Si cela est applicable au Logiciel commandé, la licence d'utilisation est limitée au nombre de poste de travail ou d’utilisateur indiqué dans le Contrat d’Abonnement.

Au cas où le Client souhaiterait augmenter le nombre maximal de poste de travail ou d’utilisateur dont il bénéficie au titre des présentes, il en avisera par écrit Visiativ qui lui accordera le droit d'utiliser le Logiciel pour le nombre de poste de travail ou d’utilisateur complémentaires en contrepartie du paiement d'un supplément de redevance calculé conformément aux prix en vigueur de Visiativ au moment de la demande.

Le Client peut effectuer une copie de sauvegarde du Logiciel, sauf si ladite copie est fournie par Visiativ ou si le Logiciel est accessible depuis le réseau Internet en mode SaaS (Software As A Service). Le Client a sur la copie de sauvegarde les mêmes droits et obligations que sur l'exemplaire du Logiciel concédé en licence au titre du présent Contrat.

En dehors des droits concédés au présent article ci-dessus et sans préjudice de ceux-ci, le Client n’est pas autorisé au titre des présentes notamment à :

— copier, imprimer, transférer, transmettre tout ou partie du Logiciel ;

— vendre, louer, sous-licencier, mettre en crédit-bail ou distribuer de quelque façon que ce soit le Logiciel ;

— utiliser le Logiciel pour fournir des services de traitement de données, de service bureau, d'exploitation en temps partagé ou d'autres services analogues de quelque nature qu'ils soient, à toute autre personne physique, société ou entité ;

— à n’utiliser le Logiciel que pour ses propres besoins, sans en faire bénéficier un tiers, sauf autorisation expresse et écrite de Visiativ.

— modifier le Logiciel et/ou fusionner tout ou partie du Logiciel dans d'autres programmes informatiques ;

— la création, le développement, la commercialisation de toute œuvre dérivée du Logiciel et/ou susceptible de le concurrencer;

— compiler le Logiciel, le décompiler, le désassembler, le traduire, l'analyser, procéder au reverse engineering ou tenter d'y procéder, sauf dans les limites autorisées par la loi ;

— réaliser des traitements ou des prestations informatiques quelconques pour des tiers en utilisant le Logiciel, notamment des travaux à façon.

Il est expressément convenu que le Client s’interdit de corriger par lui-même toute anomalie quelle qu'elle soit, Visiativ se réservant seul ce droit.

Des composants du Logiciel peuvent en tout ou partie être régis par des licences open source. Le cas échéant, certaines clauses desdites licence open source peuvent annuler les conditions de la présente Licence. Si le Logiciel intègre des composants open source, les licences correspondantes sont disponibles dans la section « Informations légales » du Logiciel.

  4. Durée. Sauf cas de résiliation anticipée du Contrat, la durée de concession de(s) licence(s) sur le(s) Logiciel(s) est précisée dans le Contrat d’Abonnement.
  5. Propriété intellectuelle. La présente licence ne confère au Client aucun droit de propriété intellectuelle sur le Logiciel et la Documentation, qui demeurent la propriété entière et exclusive de Visiativ ou de ses fournisseurs.

Le Client s’oblige à respecter les mentions de propriété figurant sur le Logiciel, les supports ou la Documentation.

Le Client s’engage à ne pas porter atteinte directement ou indirectement, par l'intermédiaire d'un tiers, et de quelque manière que ce soit, aux droits de propriété intellectuelle de Visiativ et de ses fournisseurs et notamment à ne pas mettre à la disposition de tiers le Logiciel et sa Documentation directement ou indirectement, à quelque titre que ce soit.

Tout acte de contrefaçon ou susceptible d’être ainsi qualifié, qui serait le fait de tiers et dont le Client aurait connaissance, doit être signalé à Visiativ qui fera son affaire des poursuites à mener.

  6. Mises à Jour et Maintenance. Si le Logiciel est une Mise à Jour d'une version antérieure du Logiciel, le Client doit détenir une licence en vigueur pour cette version antérieure pour pouvoir utiliser la Mise à Jour. Toutes les mises à jour sont exclusivement fournies sur la base d’un contrat d’Abonnement en vigueur. De même, Visiativ s’engage à assurer la maintenance du Logiciel selon les modalités décrites dans le contrat d’Abonnement et ce pendant la durée de ce dernier.
  7. Confidentialité. Le Client s’engage à ne pas divulguer d'informations relatives au savoir-faire de Visiativ ou autres informations ou données confidentielles. A ce titre, Le Client s’engage à garder strictement confidentiel toutes informations (notamment commerciales, techniques, financières et juridiques) échangées tant au titre de la négociation avant la signature du présent Contrat ainsi qu’au cours de son exécution, ci-après désignées « Informations Confidentielles ». Le Logiciel et sa Documentation étant notamment des Informations Confidentielles. Cet engagement se poursuivra tant que les Informations Confidentielles, y compris le savoir-faire ne sont pas tombées dans le domaine public.

L'engagement de confidentialité ne s'applique pas aux Informations Confidentielles :

a) qui sont entrées dans le domaine public préalablement à la date de divulgation ou communication ou qui tomberont dans le domaine public après leur communication et/ou divulgation sans que la cause ne soit imputable au Client ;

b) dont il peut être démontré qu'elles sont déjà connues du Client avant leur transmission ;

c) qui auront été reçues d'un tiers de manière licite, sans violation du présent Contrat ;

d) que la loi, la réglementation applicable ou une décision de justice obligeraient à divulguer. Cette communication doit alors être strictement limitée aux personnes autorisées selon la loi et s'effectuer dans le respect des droits d’Visiativ. Le Client s’engage à informer Visiativ par écrit de toute demande de communication présentée dans le cadre du présent paragraphe avec le détail des informations requises.

Le Client reconnait que toute divulgation léserait les intérêts de Visiativ et engagerait sa responsabilité.

Le Client se porte fort, au sens de l'article 1120 du Code civil, du respect par ses préposés, mandataires ou sous-traitants dûment autorisés, de l'engagement de confidentialité exposé ci-dessus.

  8. Garantie contractuelle. Visiativ garantit exclusivement la conformité du Logiciel aux caractéristiques fonctionnelles et techniques figurant dans la Documentation qui est remise au Client ou disponible en téléchargement au titre du Contrat (ou les spécifications contractuellement convenues).

A ce titre, Visiativ interviendra gratuitement, pendant 30 (trente) jours à compter de la date de livraison du Logiciel, pour tenter de corriger les anomalies.

Le Client doit remettre à Visiativ un rapport documentant l'anomalie et l'expliquant clairement.

Visiativ se réserve le droit d'utiliser le moyen le plus approprié pour effectuer la correction des anomalies : envoi d'un support magnétique, télétransmission, déplacement sur site.

La garantie ci-dessus cesse de plein droit si la configuration et/ou le Logiciel ont été modifiés par le Client ou un tiers ainsi qu'en cas d'utilisation non conforme au référentiel contractuel.

Toute intervention pour une anomalie ne répondant pas aux conditions de la garantie ci-dessus ni aux conditions de maintenance prévus dans le Contrat d’Abonnement, le Client sera facturé au tarif d'intervention en vigueur à la date de celle-ci. Tout déplacement sur site sera facturé au Client par Visiativ au tarif en vigueur.

Visiativ ne garantit pas que le Logiciel soit exempt d'anomalies et que son fonctionnement soit ininterrompu. En conséquence, il est rappelé qu'il appartient au Client de prendre toutes les dispositions pour établir les plans de dépannage adéquats et prendra toute mesure appropriée pour minimiser les conséquences dommageables liées notamment à une possible interruption d'exploitation ou à une possible perte de données générée par le Logiciel du fait de son utilisation.

Visiativ ne fait aucune autre garantie expresse ou implicite relative au Logiciel, y compris, notamment, toute garantie implicite de qualité marchande ou d'adéquation du Logiciel à un objectif particulier. Le Client a choisi le Logiciel en fonction des besoins qu’il a lui-même définis notamment à partir de la Documentation, des conseils de Visiativ, d’une société tierce ou d’un conseil choisi par le Client.

AU TITRE DE LA GARANTIE CONTRACTUELLE DU PRESENT CONTRAT, Visiativ PRENDRA EN CHARGE LA CORRECTION DES ERREURS OU LE REMPLACEMENT DU LOGICIEL DEFECTUEUX, A L'EXCLUSION DE TOUT AUTRE PREJUDICE DIRECT OU INDIRECT, NOTAMMENT LIE A L'INDISPONIBILITE DU LOGICIEL, QUELLE QU'EN SOIT LA DUREE.

PARTICULIEREMENT, Visiativ ET SES FOURNISSEURS NE GARANTISSENT PAS ET NE PEUVENT PAS GARANTIR LES PERFORMANCES OU LES RÉSULTATS OBTENUS EN UTILISANT LE LOGICIEL.

LE CLIENT UTILISE LE LOGICIEL ET LES RESULTATS OBTENUS PAR LA MISE EN ŒUVRE DU LOGICIEL SOUS SA RESPONSABILITE EXCLUSIVE, SANS RECOURS POSSIBLE DU CLIENT CONTRE Visiativ. NOTAMMENT, LA RESPONSABILITE De Visiativ NE SAURAIT ETRE ENGAGEE A RAISON D'ERREURS, QUELLE QU'EN SOIT LA CAUSE, DANS LES RESULTATS OBTENUS, QU'IL APPARTIENT AU CLIENT DE VERIFIER.

  9. Installation. Sauf recours à une prestation faisant l’objet d’une tarification distincte auprès d’Visiativ, l'installation du Logiciel sur le site sera effectuée par le Client sous sa propre responsabilité, conformément aux instructions d'installation du manuel et celles données par Visiativ.
  10. Résiliation. Chacune des Parties pourra résilier le Contrat trente-cinq (35) jours après une mise en demeure restée infructueuse, en cas d’inexécution de ses obligations contractuelles par l’autre Partie.

En cas de cessation des présentes relations contractuelles et ce, pour quelque raison que ce soit, le Client s’engage soit à restituer à Visiativ dans les 15 (quinze) jours de la fin des relations contractuelles, l'ensemble des éléments constitutifs du Logiciel, y compris les supports et toutes les copies qui en auront été faites, en garantissant par écrit l'intégralité de cette remise, soit à fournir par écrit, une attestation certifiant la destruction du Logiciel, de ses supports et de toutes les copies qui auraient pu être faites.

  11. Limitation de responsabilité. Visiativ s’oblige à apporter le meilleur soin, dans le respect des règles de son art, à l’accomplissement de ses missions. Sa responsabilité ne peut être engagée qu’en cas de négligence dont il appartient au Client d’apporter la preuve. A ce titre, la responsabilité de Visiativ ne peut être engagée en cas d’inexécution ou de mauvaise exécution du Contrat par le Client.

Le Client reconnaît qu’en aucun cas, Visiativ ou ses fournisseurs ne procède à la vérification de la configuration du système du Client et/ou à l’analyse de l’adéquation du Logiciel aux besoins du Client. Le Client reconnaît avoir reçu de Visiativ toutes les informations nécessaires lui permettant d’apprécier l’adéquation du Logiciel à ses besoins.

En cas de doute sur l’interprétation d’une clause ou en l’absence de mention permettant de déterminer l’étendue des obligations de Visiativ, le Client reconnaît que les obligations de Visiativ s’entendent comme des obligations de moyen.

EN AUCUN CAS, Visiativ ET SES FOURNISSEURS NE SERONT TENUS A REPARATION DU PREJUDICE INDIRECT NOTAMMENT PREJUDICE MORAL, PERTE DE CLIENTELE, PERTE DE RESULTATS, PERTE DE DONNEES ETC. QUE POURRAIT SUBIR LE CLIENT.

DANS SES RAPPORTS AVEC LE CLIENT, EN AUCUN CAS, SAUF FAUTE LOURDE, LA RESPONSABILITE DE Visiativ ET DE SES FOURNISSEURS NE POURRA EXCEDER LE MONTANT PAYE PAR LE CLIENT POUR LE LOGICIEL.

Toute réclamation doit faire l’objet d’une lettre recommandée avec accusé de réception adressée au siège de Visiativ dans un délai n’excédant pas un an à compter de la date de découverte des faits susceptibles de fonder ladite réclamation.

LA PRESENTE CLAUSE RESTE APPLICABLE EN CAS DE NULLITE, DE RESOLUTION OU DE RESILIATION DU PRESENT CONTRAT.

  12. Force majeure et contrainte. La responsabilité de Visiativ ne pourra être recherchée si la non-exécution ou le retard dans l’exécution de l’une de ses obligations découle d’un cas de force majeure ou d’un cas fortuit.

La force majeure comprend notamment les grèves de toute nature, les problèmes d’approvisionnement de Visiativ et notamment la rupture pour quelque cause que ce soit des contrats avec les éditeurs de Logiciels sauf rupture imputable exclusivement à Visiativ, l’incendie, l’inondation, la guerre, les émeutes, les troubles sociaux, les arrêts de production dus à des pannes fortuites.

  13. Audit. Visiativ se réserve le droit d’effectuer des audits à ses frais dans les locaux du Client pendant la durée du Contrat afin de contrôler la bonne exécution du Contrat. Visiativ préviendra le Client par écrit de cet audit, trente jours ouvrables au moins avant celui-ci. Cet audit sera réalisé conjointement avec le Client pendant les heures ouvrables normales du Client, et ne devra occasionner aucune gêne excessive pour ses activités. Visiativ pourra procéder au maximum à deux audits par période de douze (12) mois pendant la durée du Contrat.

Le rapport d’audit sera présenté au Client. Il est expressément convenu qu’en aucun cas la durée de cet audit ne pourra excéder trois (3) jours. Si un audit révèle que le Client ne se conforme pas aux termes du présent Contrat, les parties se réuniront pour chercher une explication et une solution.

  14. Loi applicable. LES PRESENTES AINSI QUE LES OPERATIONS QUI Y SONT VISEES SERONT REGIES PAR LA LOI FRANCAISE.

LES TRIBUNAUX de LYON SONT SEULS COMPETENTS POUR CONNAITRE DES CONTESTATIONS POUVANT NAITRE A QUELQUE TITRE QUE CE SOIT DU PRESENT CONTRAT

  15. Conformité aux licences. Si le Client est une société ou une organisation, il s’engage à prouver et certifier, dans un délai de trente (30) jours, à la demande de Visiativ ou d'un de ses représentants autorisés, qu'à la date de ladite demande, l’Utilisation des Logiciels est conforme aux licences en vigueur concédées par Visiativ.
  16. Dispositions générales. L’annulation éventuelle d’une des clauses ou un des alinéas figurant dans les présentes conditions générales, notamment par une décision de justice, ne saurait porter atteinte aux autres dispositions qui continueront d’avoir leur plein et entier effet.

Le fait pour l’une des Parties de ne pas se prévaloir d’un manquement par l’autre Partie à l’une quelconque des obligations visées dans les présentes, ne saurait être interprété pour l’avenir comme une renonciation à l’obligation en cause.

Pour toute demande d'information, veuillez-vous adresser au Service Clientèle de Visiativ.


Présentation de l'utilitaire "CuttingOptimization"

Cet utilitaire permet d'ordonnancer les découpes et d'optimiser les chutes des conceptions à base de profilés. Cet outil vous permettra d'optimiser vos approvisionnements matière et ainsi diminuer considérablement vos coûts de fabrication.

Avec CuttingOptimization vous pouvez utiliser directement les tables de mécano-soudé SolidWorks ou bien saisir manuellement votre nomenclature de profilés.


Utilisation de l'utilitaire "CuttingOptimization"

Les fonctionnalités de CuttingOptimization :

  • Création d'une base de données de profilés .
  • Il est possible de créer un projet depuis une table mécano-soudée ou de créer un projet et de saisir manuellement la nomenclature de profilés.
  • A l'aide des réglages des options il est possible de spécifier un certain nombre de paramètres tels que l'emplacement par défaut des projets et des fichiers de résultats.


Barre d'outils "CuttingOptimisation"

Utilisation de l'utilitaire "CuttingOptimization" ››

- L'icône [image] permet d'ouvrir un nouveau projet .

- L'icône [image] permet d'ouvrir un projet déjà enregistré .

- L'icône [image] permet d'enregistrer un projet qui a déjà été sauvegardé.

- L'icône [image] permet d'enregistrer un nouveau projet.

- L'icône [image] permet d'ouvrir la fenêtre d'options .

- L'icône [image] permet d'ouvrir le gestion des bases de profilés .


Options

Utilisation de l'utilitaire "CuttingOptimization" ››

Pour ouvrir le panneau d'options, vous pouvez utiliser l'icône "Options" [image] .

  • Emplacements :

- Emplacement par défaut des projets :

Avec le bouton [image] , sélectionner un dossier pour sauvegarder les projets. Par défaut la sauvegarde des projets se fait dans le dossier d'installation de l'utilitaire.

- Emplacement du fichier XML résultat :

Avec le bouton [image] , sélectionner un dossier pour sauvegarder le rapport au format XML.

- Emplacement du paramétrage :

Avec le bouton [image] , sélectionner un dossier pour sauvegarder le fichier XML de paramétrage de l'utilitaire.

- Emplacement des bases de profilés :

Avec le bouton [image] , sélectionner un dossier pour sauvegarder vos bases de profilés personnalisés.

  • Repérage/Propriétés :

Lors de l'édition du rapport , ajouter aux barres de profilés des repères numériques ou alphabétiques.

- Texte affiché en bas du rapport :

Cette option permet d'afficher un texte personnalisé en bas de page du rapport.

  • Unités/Précision :

- Choix de l'unité et de la précision Linéaire/Angulaire :

- Spécifier une longueur de chute ''récupérable' par défaut.

- Réglage par défaut de la largeur de coupe.

les réglages de la partie "Unités" sont modifiables directement dans les projets.

  • Rapport :

Dans les options il est possible de définir certains paramètres pour la création du rapport ainsi que l'export dans des formats d'impression.

Les formats de fichier disponibles proposés sont les imprimantes déclarées sous votre session Windows. Auparavant seul l'export en XPS était disponible, il est désormais possible d'enregistrer au format PDF.

Il est également possible de sélectionner les éléments à faire apparaître dans le rapport. En effet dans certains cas il peut être souhaitable de n'exporter que les fiches des coupes et pas le récapitulatif du projet complet.


Base de données profilés

Utilisation de l'utilitaire "CuttingOptimization" ››

La base de données profilés est une bibliothèque qui répertorie toutes les barres de profilés que vous utilisez dans votre atelier. Lorsque vous lancez un projet, CuttingOptimization récupère dans cette base toutes les informations afin d'optimiser les découpes et les chutes des conceptions à base de profilés.

  • Création des bases de données profilés :

- La création des bases de données se fait directement dans Excel (Enregistré en .csv), fichier Excel qui doit être enregistré dans le dossier défini dans les options d'emplacements. (Par défaut dans le dossier "Bases", du dossier d'installation de l'utilitaire).

  • Gestion des bases de données profilés :

Pour ouvrir la gestion des bases de profilés, il faut utiliser l'icône [image] .

Cette fenêtre permet de visualiser vos bases de données, il est aussi possible d'afficher les options d'emplacement de ces bases et d'éditer les tables.

- Modifier l'emplacement des bases :

Cette option permet d'afficher la fenêtre d'options pour modifier l'emplacement des bases de profilés.

- Bases disponibles :

Ce menu déroulant affiche toutes vos bases de profilés et permet de sélectionner une de ces bases pour l'afficher dans la fenêtre de gestion.

- Éditer la table :

Le bouton [image] permet d'ouvrir le fichier Excel (.csv) de la base affichée dans la fenêtre pour la modifier.

Après modification du fichier, enregistrer le fichier en .csv


Création d'un projet

Utilisation de l'utilitaire "CuttingOptimization" ››

Pour ouvrir la fenêtre d'un projet, il faut utiliser l'icône [image] (Nouveau projet) ou bien ouvrir un projet déjà sauvegardé avec l'icône [image] .

Dans cette fenêtre de projet, nous allons pouvoir renseigner :

  • Les informations du projet .
  • Dans le cadre "Machine & barres" , choisir les longueurs de barres et paramétrer les informations machine.
  • Ajouter une liste de profilés à insérer au projet dans le cadre "Saisie des éléments du projet" .


Information du projet

Utilisation de l'utilitaire "CuttingOptimization" ›› Création d'un projet ››

Dans ce cadre, il est possible de renseigner des informations sur le projet en cours.

Ces informations sont reprises dans le rapport.

- Quantité :

Cette option permet de gérer la quantité au niveau du projet.

Exemple :

Le projet comporte 10 coupes pour le profil "Carré006" et 20 coupes pour le profil "Carré012".

- Avec l'option

Le rapport comporte bien le nombre de coupes définies dans le projet.

- Avec l'option

Dans le rapport la quantité des coupes définies dans le projet est multipliée par 2.


Machine & barres

Utilisation de l'utilitaire "CuttingOptimization" ›› Création d'un projet ››

  • Choix des longueurs de barre :

- longueurs de barre :

Cette option permet d'imposer une longueur de barre pour tous les profilés.

Cette option permet de définir une longueur de barre pour chaque profilé.

Voir le paragraphe " Définir la longueur de barre par profil ".

- Gestion des chutes :

Si vous avez des chutes dans votre stock, vous pouvez renseigner ici leurs longueurs, elles seront prises en compte pour la découpe des éléments.

  • Machine :

- Largeur de la lame :

Par défaut la largeur de coupe est récupérée depuis les options . Cette valeur est modifiable pour le projet actif.

- Chute initiale :

Partie soustraite de la longueur de la barre avant optimisation : cette partie correspond aux différentes pertes liées aux différentes machines de sciage (dans le cas d'une machine double lame, correspond au "re-sciage" systématique de chaque longueur, ou dans le cas d'une machine simple lame cela correspond à la préemption de la barre, etc ...).


Saisie des éléments du projet

Utilisation de l'utilitaire "CuttingOptimization" ›› Création d'un projet ››

Ce cadre permet de définir une liste de profilés et de renseigner tous les éléments à découper. Pour accéder à cette fenêtre il faut utiliser l'icône [image] , Il est aussi possible d'ouvrir un projet déjà enregistré avec l'icône [image] .

  • Ajouter des éléments :

- Ajouter des éléments manuellement :

L'icône [image] permet d'ajouter des éléments dans la listes des débits.

Une fois l'élément ajouté, il faut double-cliquer dans la colonne "Profilé" pour afficher le menu déroulant comportant la liste des bases de profilés.

Si vous avez plusieurs bases de profilés (Plusieurs fichiers .csv), elles apparaîtront toutes dans le menu déroulant.

Sélectionner le profilé voulu et modifier la "Longueur" et la "Quantité" en double cliquant sur les colonnes correspondantes.

Il est également possible d'appliquer une couleur au repère en double cliquant sur la cellule correspondante.

Cette couleur apparaîtra ensuite dans le rapport pour plus de visibilité sur les coupes.

Cliquer à nouveau sur l'icône [image] pour ajouter un nouvel élément.

Il est possible de modifier les colonnes définies dans CuttingOptimization, voir le paragraphe " Gestion des colonnes "

- Ajouter des éléments à partir d'une table de mécano-soudé :

L'icône [image] permet de créer un projet en récupérant les éléments d'une table de mécano soudé SOLIDWORKS.

Voir le paragraphe " Création d'un projet depuis une table ".

  • Angle de coupe :

Il est possible de définir un angle de coupe pour chaque profil.

Les coupes "Angle gauche" et "Angle droit" sont définies selon la règle suivante :

  • Positionnement :

Lors de l'utilisation des coupes en angle, il est possible de spécifier l'orientation du profil.

Pour spécifier une orientation, sélectionner le profil et cocher l'option "Spécifier l'orientation".

- Le menu déroulant [image] permet de sélectionner le type du profil.

- Les icônes [image] permettent la rotation du profil sélectionné.

- Le dessin [image] représente la lame.


Gestion des colonnes

Utilisation de l'utilitaire "CuttingOptimization" ›› Création d'un projet ›› Saisie des éléments du projet ››

Il est possible de personnaliser les colonnes par un clic droit sur l'une des en-têtes, puis sélectionner : Gestion des colonnes

Cette commande permet de désactiver, ajouter ou supprimer des colonnes :

  • Pour masquer une colonne, il suffit de décocher la ligne correspondante :

  • Pour supprimer une colonne, il faut faire un clic droit sur la ligne correspondante et choisir "Supprimer la colonne personnalisée":

  • Pour ajouter une colonne, il faut faire un clic droit sur la ligne correspondante et choisir "Ajouter une colonne personnalisée" :

Un double-clic sur la ligne du "Nom" permet de renseigner une en-tête personnalisée, ceci est également valable pour les lignes existantes.

Exemple, ajoutons la colonne "Matériau" qui est une propriété d'un article de pièce soudée de la table de nomenclature, il faut respecter la syntaxe et la casse du nom de la propriété. Ensuite il existe deux types de propriétés, "Simple propriété" et "Propriété différenciatrice" (double cliquer sur le type de la colonne "Type").

  1. Une "Simple propriété" permet de renseigner des informations sur le profil :

  2. Une "Propriété différenciatrice" permet de différencier des profils de formes identiques selon un autre critère.

Par exemple, dans ce cas, si la propriété "Matériau" est de type : "Propriété différenciatrice", le repère 4 sera optimisé de façon indépendante :


Définir la longueur de barre par profilés

Utilisation de l'utilitaire "CuttingOptimization" ›› Création d'un projet ››

Lorsque l'option " Définir par profilés " est cochée, des onglets seront ajoutés à la zone de saisie. Ces onglets permettront de spécifier pour chaque type de profile :

  • Choix des longueurs de barre :

- Longueur "Imposée" :

Ici nous retrouvons le choix tel que défini dans la zone " Machine & barres ". Possibilité de réutiliser des chutes.

Avec l'option "Imposée" cochée, toutes les autres options sont grisées.

- Longueur "Déduite entre ..." :

Cette option permet de donner une plage dans laquelle l'outil va calculer la longueur optimum pour obtenir un minimum de chutes. Cette option permet également de demander un calcul de deux longueurs optimum.

  • Analyse graphique :

Le bouton [image] permet de calculer la longueur de barre optimale pour obtenir un minimum de chute.

Le graphique apparaît uniquement dans le cas où on demande à l'utilitaire de calculer la longueur de barre optimale et que cette longueur n'est pas imposée dans la zone "Choix des longueurs de barre".

L'option [image] permet de modifier la finesse d'itération suivant ce calcul :

(Lg max - Lg min)/finesse, soit pour l'exemple ci-dessus (7000-4000)/100 = 30 itérations.

Dans ce graphique, sont visualisés :

- En rouge les principales longueurs optimisées et conseillées par l'outil.

- En bleu le % de chute pour une longueur de barre donnée.

- En vert le nombre de barres nécessaires.

Exemple :

Si je lance l'analyse avec les paramètres ci-dessus :

Il apparaît, lors de l'analyse, que la barre optimale pour obtenir un minimum de chute est une barre de 7000 (4.87% de chute). Par défaut le rapport prendra en compte la barre optimale.

Si vous voulez utiliser une autre longueur de barre, il faut forcer la longueur dans "Longueurs des barres brutes".

Par exemple : Utiliser une barre de 5500.

Le rapport prendra en compte la barre sélectionnée.

  • Séparer les débits en lots :

Dans le cas où on demande un nombre de longueurs de barres à déterminer >1 [image] , l'outil va séparer les grandes longueurs des plus petites. Ici l'utilisateur va pouvoir intervenir sur la longueur de séparation des lots.

- Exemple avec une liste de débits comportant des longueurs différentes.

Le bouton [image] permet d'afficher les différentes longueurs de barres.

Le curseur permet de sélectionner la longueur de séparation des lots.

Un lot en bleu, avec les coupes de longueur 800; 1000; 1210

Un lot en rouge avec les coupes de longueur 200; 100; 50

- Après avoir défini les lots, il faut lancer l'analyse graphique pour calculer les longueurs de barres optimales.

Il apparaît, lors de l'analyse, que la barre optimale pour le lot en bleu est une barre de 5200 (3.75% de chute) et pour le lot en rouge de 5400 (1.36% de chute). Par défaut le rapport prendra en compte ces barres.

Si vous voulez utiliser une autre longueur de barre, il faut forcer la longueur dans "Longueurs des barres brutes".

Le rapport prendra en compte les barres sélectionnées.

Il est possible d'imposer seulement la longueur 1 ou la longueur 2.


Création d'un projet depuis une table

Utilisation de l'utilitaire "CuttingOptimization" ››

Pour lancer la création d'un projet depuis une table d'éléments de mécano-soudés, il faut utiliser l'icône [image] .

  • Sélection des profilés :

Après avoir sélectionné l'icône, la fenêtre de sélection apparaît.

Pour récupérer les profilés dans CuttingOptimization, il faut cliquer dans la fenêtre de sélection pour l'activer :

Et sélectionner la table de mécano-soudés dans la mise en plan SOLIDWORKS.

Tous les profilés de la table de mécano-soudés sont insérés dans le tableau de correspondance de profilés de CuttingOptimization.

Vous avez la possibilité de supprimer la sélection avec le bouton [image] .

  • Tableau de correspondance des profilés :

Dans la première colonne, on retrouve la désignation des profilés dans la table de mécano-soudés et dans la deuxième les noms des profilés que l'on a créés dans la base de données profilés .

Pour que la colonne "Nom dans la base" se remplisse automatiquement, il faut que la désignation des profilés dans SOLIDWORKS correspondent exactement aux noms des profilés entrés dans la base de données des profilés créée dans CuttingOptimization.

Si les noms ne correspondent pas, la colonne "Nom dans la base CuttingOptimization" peut être vide ou partiellement remplie. Dans ce cas vous pouvez sélectionner manuellement un profilé dans la base CuttingOptimization.

Cliquer sur [image] pour valider le tableau et créer les projets.

  • Projet :

Le projet est créé et renseigné automatiquement.

Il est possible de modifier chaque repère en éditant les éléments du projet, comme vu dans le chapitre "Création d'un nouveau projet" .

Vous pouvez maintenant éditer le rapport de chaque projet.


Édition du rapport

Utilisation de l'utilitaire "CuttingOptimization" ››

Pour éditer le rapport, utiliser le bouton [image] .

Exemple de rapport pour ce projet :

Le rapport comporte deux parties :

Sur la feuille 1 un rapport texte.

Sur la feuille 2 un rapport graphique.

Les colonnes (propriétés) rajoutés apparaissent dans l'édition du rapport.

Exemple ci-dessous, il y a 2 colonnes qui ont été ajoutées "Désignation" et "MATIERE".

Le résultat du rapport donne :